why do my poached eggs smell funky

3
10
Joined May 23, 2015
Hi

I've recently moved to a new place and my poached eggs now come out smelling weird! It's a sort of smell like if you haven't air dried your clothes properly, ugh its horrible! It's much worse if I catch a bit of the boiled water onto the english muffin, so I have a feeling it might be the water itself (ew!)

I've tried all the below but still have this problem:

* Washing all cutlery by hand to rule out the dishwasher

* Descaling the kettle to rule that out (I add the boiling water to the pan)

* Using super fresh eggs and english muffins (i.e. cooking it the same day to rule out the fridge)

* Adding white vinegar to the boiling water, no difference, still smells funny!

It's worth noting it doesn't taste off, but smells a little funky!

Could there be something wrong with our water supply? I don't know what else it could be.. Other food I make is fine, like a curry, which probably masks whatever it is. But its very noticeable with poached eggs.

Any help really appreciated /img/vbsmilies/smilies/smile.gif
 
47
10
Joined May 22, 2015
Try using bottled water, and see if it still smells funny..if so, it could be the water....

In Florida, our "wonderful" city water smells like rotten eggs from time to time ( sulfur )...so we got a water softener + de-chlorinator and it seems to help.

@babyemerald
 
Last edited:
4,759
1,011
Joined Aug 21, 2004
When you poach your eggs do you use water out of the hot water tap? If so, it could be the hot water heater because they build up mineral deposits over the years and can produce some pretty funky tasting water. Do a side by side tasting comparison between the hot and the cold tap.
 
5,192
296
Joined Jul 28, 2001
I have to ditto @cheflayne

What collects are the insoluble salts. Usually Calcium and Magnesium. You might try to extract some water from your hot water heater and see if it smells even worse. Sometimes just emptying the heater and refilling can help. The sediments build up and accumulate on the bottom.  It could very well be the pipes delivering the water.

Sometimes just changing the faucet can help a lot.

I'm curious what material your kettle is made out of. It too can become porous inside over time.

Probably the best bet would be to call in a water delivery co. and a dispenser. Hth's
 
Last edited:
7,675
842
Joined Apr 3, 2008
I too would use bottled water and see if it works.  Or check your vinegar, sometimes depending on what vinegar you use it affects the flavor of the poached egg.  And don't use too much, I hate it when my eggs benedict come out out smelling like vinegar.  Bad!

Oh and by the way, you shouldn't be putting a wet poached egg on an english muffin.  First place it on a paper towel, it will absorb the excess water and then place it on the muffin.
 
3
10
Joined May 23, 2015
Thanks guys, some great suggestions. I've just made myself another poached egg this morning and it was a bit better. Changes I made:
  • A brand new silicone egg poacher (nothing wrong with the old one - but worth a shot!)
  • Minimal olive oil as possible when coating the egg poacher
I checked the water after I was done, still a little funky. Could it be Olive Oil that I'm using? hmmm

I live in a flatshare so not sure how long this kettle has been around. The element was completely covered in hardwater and would take far too long to boil water. Using a kettle descaler solved that problem, but your probably right @panini  , the plastics in there maybe have become porous. It's just a cheap plastic kettle after all

I'm going to try the bottled water suggestion next, if that doesn't work at least I can rule the water supply out, which means it's probably the kettle

@Koukouvagia  I've been using a separate plate, but will be using a paper towel from now on ;) btw - because of the silicone pouch, I don't have to use vinegar at all, it was just a test to see if it tasted any different but a good shout

Almost forgot to mention, the water is from the cold tap only, I use the kettle to bring it the boil and use that to poach the egg in
 
Last edited:
3
10
Joined May 23, 2015
Just thought I'd report back. New kettle and problem was solved! :)

Thanks to all that replied on this!
 
Top Bottom